Home Forums WP Content Resharer Pro Unable To Setup Facebook Connection

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #17832
    AvatarDustin Cabeal
    Participant

    Hello,

    I’ve been trying to set up my Facebook connection, but the walkthrough in the help section seems to be outdated. Is there a new walkthrough because I’m unable to connect and activate it.

    Also, any plans for a Google+ connection?

    Thanks

    #17847
    AvatarCharlie
    Keymaster

    Hello Dustin,

    You’re right, Facebook has changed their interface. Here is an updated version of the instructions:

    These directions will be shown from the perspective of creating a new application, but you can use an existing one.

     1. Go to your Facebook developer applications page.

     2. Click the “Add a New App” button and hit the “Website” icon when prompted.

     3. Fill out a name for the application, then a hit “Create New Facebook App ID”.

     4. Enter a contact email then choose a category then hit “Create App ID”.

     5. Scroll down to the “Tell us about your website” section and enter in your website URL (i.e. http://mywebsite.com), then hit “Next”.

     6. Scroll all the way up and hit the “Skip Quickstart” button at the top right of the page.

     7. Navigate to the “App Review” menu page in the left side menu. Once inside, make sure the setting “Your app is in development and unavailable to the public” is set to “YES”, then hit “Confirm”. Also, make sure your application is Live and not in test mode, it should now say “Your app is currently live and available to the public”.

     8. Navigate to the “Dashboard” menu page in the left side menu. You will need the following keys and tokens to connect your Facebook account to Content Resharer Pro. If you want to post to a page, then you will need to find your page ID.

      App ID

      App Secret (hit the “Show” button)

    #17868
    AvatarDustin Cabeal
    Participant

    Hi Francisco,

    Thank you for the updated walkthrough. I did that and it seems to have been set up, but now it’s saying “Not Connected: Link account” I clicked that link and connected my account giving it access to my facebook account and page, but the status hasn’t changed.

    Thank you,

    Dustin

    #17869
    AvatarCharlie
    Keymaster

    Does it still say “Not Connected: Link account”?

    Are you logged in at Facebook.com with the same account you created the App and you want Content Resharer Pro to post to?

    #17870
    AvatarDustin Cabeal
    Participant

    Hi,

    I just double checked and it still says “Not Connected: Link Account”

    I am logged in to the same facebook account that I created the app with.

    #17871
    AvatarCharlie
    Keymaster

    Very strange, is there any additional error message?

    If not, could you try to uninstall and then reinstall Content Resharer Pro?

    #17872
    AvatarDustin Cabeal
    Participant

    There’s no other error messages, I did receive a warning on Facebook when connecting. I don’t recall exactly what it said. I think it was along the lines of needing to get the app approved.

    I will attempt to uninstall and reinstall the plugin later today and get back to you with the results.

    Thanks,

    Dustin

    #17873
    AvatarCharlie
    Keymaster

    I see, do you remember changing the Facebook App from testing to live when you created it? (Step NÂș 7)

    #17875
    AvatarDustin Cabeal
    Participant

    Yes I did.

    This is what it says on the facebook app: Your app is currently live and available to the public.

    #17935
    AvatarCharlie
    Keymaster
    This reply has been marked as private.
    #17936
    AvatarDustin Cabeal
    Participant

    Hi Francisco,

    Actually I just figured it out. I was using my custom facebook address and it needed the number so after I figured that out and tried it again it worked and says that the connection is good. Sorry for all the hassle. I should have known better.

    Thank you!

    #17956
    AvatarDustin Cabeal
    Participant

    Hi,

    Sorry to reopen this thread. After finally getting everything set up, I’m not actually seeing it post to Facebook at all. The plugin has posted to Twitter a few times here and there, but nothing on Facebook so far. Wasn’t sure if that was normal or because of the problems I had setting it up?

    Thanks,

    Dustin

    #17975
    AvatarCharlie
    Keymaster

    Hey Dustin,

    Does it post to Facebook when you click on “Reshare now”?

    #17978
    AvatarDustin Cabeal
    Participant

    I got the following error when I tried that

    https://1drv.ms/i/s!AqNrADClEUW1n4EOJz2GYxPQZ6okjQ

    #17981
    AvatarCharlie
    Keymaster

    What happens when you go to Edit > Content tab > and uncheck Embed Link?

    Try “Reshare now” this time and see if it works or if you get another error message.

    #17982
    AvatarDustin Cabeal
    Participant

    That worked! Thank you!

Viewing 16 posts - 1 through 16 (of 16 total)
  • The forum ‘WP Content Resharer Pro’ is closed to new topics and replies.
-