Home Forums WP Tag Manager Media Tags

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #5150
    AvatarCharlie
    Keymaster

    Hi :)

    Great plugin … nice work! I just bought it and I am testing it out.

    Works great on post and pages … but I also have the default wordpress tags panel active in the Media Library. However the Tag Manager does not work here … the tag manager box appears but selecting a tag does not add it to the media item or in the default wordpress tags panel.

    How can I make it work in the media section?

    Many thanks in advance

    #5169
    AvatarCharlie
    Keymaster

    Hello,

    Im glad you like the plugin so far and that its working for posts and pages. However, I am confused about what your problem is. So you have selected on the settings page to display the default WordPress Tags Panel. Just so you understand, the new WPsite Tags Panel and the default WordPress tags panel will work independently. So if you already have 5 tags in a post and then install this plugin, those 5 tags will still be there. If you then include 3 more tags through the WPsite Tags Panel then your post will have 8 tags. As you can see these two panels are mutually exclusive and do not depend on each other. Thats why we offer the option to include or exclude the default WordPress Tags Panel, because you don’t necessarily need it.

    Now I don’t understand what you mean by Media Library. Are you talking about the Media Library that WordPress uses to store images? If so, then it is correct that the WPsite Tags Panel is not there because images do not have tags. This is the part that is confusing to me because your stating that the Tag Manager works there. However, on my site there is no Tag Manager Panel in my Media Library, which is intended.

    Overall, if you can be a little clearer on where the Tag Manger Panel is being show that would be helpful. For example, explain where exactly this Tag Manager Panel is showing (i.e. under the Posts->Add New menu page).

    #5168
    Avatarprojectmunton
    Participant

    Hi … thanks for the quick reply :)

    Sorry … I have manually added the default wordpress tags panel so it appears in the Media Library also … I did this by adding some additional php to the functions.php

    So I now have the same tags and categories which would normally be available in post … available for me in the media library also (great refining images).

    So with your plugin the Tag Manager also appears in the media library for me … but when I select a tag in the Tag Manager … it doesn’t save to the image or in the default wordpress tags panel.

    Could the Tag Manager be assigned to work with only specific post types? if so is there somewhere I could update the code to include the media library?

    If there is anything else you need me to check let me know :)
    Many thanks again

    #5167
    AvatarCharlie
    Keymaster

    Ok I understand the question now. It would be a big help if you could supply your WordPress admin login credentials so I can see why the tags are not saving. If you do supply these credentials please make sure to make the post as private.

    #5162
    AvatarCharlie
    Keymaster

    Ok I think the problem is the way you named the plugin folder. I see that you changed the name to “Tag Manager”. Try to reinstall the plugin with the folder named something like “wpsite_tag_manager”. Let me know if this fixes things for you.

    #5161
    Avatarprojectmunton
    Participant

    Hi … thanks for the quick reply:)

    I have made that change and added the updated version … I have noticed that the admin for the plugin now has all the right styles, but the tags are still not added to the default wordpress tags panel when selected and published.

    #5160
    AvatarCharlie
    Keymaster

    Ok we fixed the one issue at least haha :) Now the only way to really see whats going on is for me to get access to your server. Is it possible for you to give me your FTP login credentials?

    #5159
    Avatarprojectmunton
    Participant

    Exactly ;)

    Unfortunately our policies mean I cannot give FTP login credentials even in test setups … it was tricky to get WP login access signed off

    Maybe you could let me know what to check or test and I can implement

    #5158
    AvatarCharlie
    Keymaster

    Its very weird how the tags save for posts but not for media images. Anyways, without having access to your server files its not possible for me to determine whats going wrong. All I know is that it has to do with your plugin you have installed to add tags to media images. Since our plugin works as advertised, I regret to inform you that there is nothing more I can do without FTP access.

    Also, it would be hard for me to explain to you what to check and test for while modifying your server files. Sorry for the bad answer but its all I can do :(

    #5157
    Avatarprojectmunton
    Participant

    Thanks again for the quick reply :)

    The other plugin doesn’t have any effect, in this regard … as the tag addition to the media library is done through a small bit of code added to the functions.php (which I have added below) … I have delated the other plugin now … so essentially it is a basic theme with the Tag Manager plugin.

    I was hoping it would be very easy to replicate locally, negating the need for FTP access.

    Really the only issue is the tags don’t save when selected … they even appear in when you click on the “Choose from the most used tags”

    // apply category to attachments
    function wptp_add_categories_to_attachments() {
        register_taxonomy_for_object_type( 'category', 'attachment' );
    }
    add_action( 'init' , 'wptp_add_categories_to_attachments' );
    
    // apply tags to attachments
    function wptp_add_tags_to_attachments() {
        register_taxonomy_for_object_type( 'post_tag', 'attachment' );
    }
    add_action( 'init' , 'wptp_add_tags_to_attachments' );
    
    #5156
    AvatarCharlie
    Keymaster

    If thats the only other code on your site then I will definitely test it out. Is it possible to paste in the code again. The text editor seemed to have escaped some characters. :)

    #5155
    Avatarprojectmunton
    Participant

    Cool … thanks :)

    // apply category to attachments
    function wptp_add_categories_to_attachments() {
    register_taxonomy_for_object_type( ‘category’, ‘attachment’ );
    }
    add_action( ‘init’ , ‘wptp_add_categories_to_attachments’ );

    // apply tags to attachments
    function wptp_add_tags_to_attachments() {
    register_taxonomy_for_object_type( ‘post_tag’, ‘attachment’ );
    }
    add_action( ‘init’ , ‘wptp_add_tags_to_attachments’ );

    #5154
    AvatarCharlie
    Keymaster

    Ok I figured out the issue :) I will upload it to Code Canyon tonight and you should receive an email once it has been approved.

    #5153
    Avatarprojectmunton
    Participant

    Cool … thats great :)

    Many thanks again for the quick responses and the fix

    Will add a 5 star rating

    #5152
    AvatarCharlie
    Keymaster

    Thank you :)

    We are also a development company that takes on custom design and development projects. So, if you ever find yourself in need of custom development work for a website or mobile app please feel free to email me kyle@wpsite.net.

    #5151
    Avatarprojectmunton
    Participant

    Cool …thanks, will keep it in mind :)

    Just tested the plugin … works great

    Thanks again

Viewing 16 posts - 1 through 16 (of 16 total)
  • The forum ‘WP Tag Manager’ is closed to new topics and replies.
-