Home Forums WP Content Resharer Pro Facebook and LinkedIn not working

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #5601
    AvatarCharlie
    Keymaster

    Hello Support Team (kjbenk :) ).

    I just tried WP Content Resharer Pro the first time today. Unfortunately not successful. Twitter works fine. But Facebook and LinkedIn not at all. I noticed that some time passed since you made the video (I did it not step by step… isn’t helping… but I found the (maybe) error like this).

    Facebook: Everything is the same like in your video. But in the last step, when the Content Resharer has to be connected with Facebook is a (probably) key difference. I get the first message (“Submit for Login Review Some of the permissions below have not been approved for use by Facebook. … bla bla”). But the next screen is not (“… would like to post publicly to Facebook…”). It is straight the last screen (“…would like to manage your Pages…”).
    The connection between my Website and the Facebook app fails. No Access token is written in the account.

    I suppose Facebook has been changed something again. Or did I made any mistake while setting up the Facebook app? (There were also some small differences to the video… due to some changes which Facebook made.)

    LinkedIn: Also here some things changed since the tutorial video. Everything looks and works different now. I tried to stick to the tutorial and try to guess what to do at the areas which has been changed. So far everything was ok, until the “Link account” process again. Same thing. It’s not connecting to my LinkedIn app. No Access token is shown in the account.
    Once thing I just found out now is that the scopes are different. And LinkedIn gives the following URL back:
    http://bloglesen.com/wp-admin/admin.php?page=wpsite-reshare-menu&linkedin=authorization&account=LinkedIn&error=invalid_scope&error_description=Your+application+has+not+been+authorized+for+the+scope+%22r_contactinfo%22

    I checked the scopes. You give more than I have available in the LinkedIn App setting. I have only for to choose there: r_basicprofile, r_emailaddress, rw_company_admin, w_share

    I tried to modify your ‘Link account’ link, to set only this 4 scopes and it was leading me to an authorisation screen of LinkedIn (authorisation to give my app access to my LinkedIn account). I logged in there and clicked on approve (or whatever the button is called in English). Then it was leading me back in my Blog backend, to the plugin accounts. But still no connection to LinkedIn. Still no OAuth User Token.

    I guess that the access rules to Facebook and LinkedIn have been changed. Could you please check it.

    #5614
    AvatarCharlie
    Keymaster

    Hello gordon,

    Thanks so much for the detailed post :) Its always great to help someone out that it willing to thoroughly explain their problem.

    Facebook

    Are you using a Facebook page or profile? Have you tried to log out of Facebook before you click the Link Account button? Being logged out when clicking the Link Account button ensures that you will get to the authentication screen.

    Facebook did recently change there authentication process, but we accounted for this change in the last update version 1.5.3. Just for a sanity check I tried to connect my personal Facebook user account to Content Reshare Pro and everything went just fine. Please double check that your application is setup properly.

    LinkedIn

    Sorry that the tutorial is outdated, we are just so busy releasing new products to market :) The scope parameter of the authentication URL accepts any of the permissions from the LinkedIn API, but Content Resharer Pro uses these:

    • r_basicprofile
    • r_fullprofile
    • r_emailaddress
    • r_network
    • r_contactinfo
    • rw_nus
    • rw_company_admin
    • rw_groups
    • w_messages

    So please make sure you have at least all of these permissions checked for your application.

    Please let me know if you still are having trouble connecting your accounts.

    #5613
    Avatargordon
    Participant

    Hello kjbenk.

    Facebook
    I try to post on a profile.

    I logged out of my Facebook account and tried then to connect Content Resharer with the Facebook app. I had to log in again and then just the 2 screens which I had before already. No changes.
    I don’t get the screen ‘in the middle’ were it says ‘…would like to post on Facebook for you…’.

    LinkedIn
    No problem. Internet life is fast. But like this I have to bother you :)
    Ok, as I mentioned, seems like the permissions of the LinkedIn API have changed. “…&error=invalid_scope&error_description=Your+application+has+not+been+authorized+for+the+scope+”r_contactinfo””(… the last part was missing in my message above, sorry). If I remove the scope r_contactinfo from the link, then next time the same message comes back from LinkedIn, but with r_fullprofile. If I remove this scrope also from the connection link, then no error message appears anymore. But still the message “Not connected: Link account” is shown in the overview of the accounts.

    I uploaded a screenshot of the permissions, which I can choose in my LinkedIn Developer area. (http://t62i.imgup.net/linkedin488c.jpg)

    #5612
    AvatarCharlie
    Keymaster

    First lets just go over the LinkedIn problem.

    I am unsure why are you seeing a different application page then me. Just like the screenshot above I have the ability to select all the permissions.

    Did you setup your application in a custom way at all?

    #5611
    Avatargordon
    Participant

    I just registered completely new yesterday at LinkedIn. Maybe that’s why I don’t see all this permissions? Today still the same.
    After registration I made my application according to the video.

    Just checked the LinkedIn app again. Still only this 4 permissions available.

    In the overview of ‘My applications’ is this app listed under ‘private’. Maybe there is also a ‘business’ with more permission levels?

    #5610
    AvatarCharlie
    Keymaster

    I just created a new app toady I can now see that the Default Permissions for LinkedIn applications have changed. I will change the the scope parameters for the LinkedIn authentication process and update the plugin on 5/1/15.

    Once we figure out the LinkedIn issue fixed we can move on to the Facebook issue.

    #5609
    AvatarCharlie
    Keymaster

    We were able to get the update our earlier than expected. Please go ahead and update to version 1.5.5 via the WordPress plugins screen. This update fixes the bug with connecting a LinkedIn account. Please verify that you are able to connect and then we can fix the Facebook problem.

    #5608
    Avatargordon
    Participant

    Hello kjbenk.

    Sorry for the delay.
    I updated the plugin and this permission error is gone. That is fixed.
    But still I have no linked account to LinkedIn. If I click now on ‘Not connected: Link account’ then the page is forwarding me to LinkedIn and I see the page where LinkedIn is asking me if I want to give my app permission to do this and that. I enter my LinkedIn login details and click on ‘Yes, give access’ (Or something like this… my one is in German). Then I get redirected back to my blog admin area… and that’s it. Not connected.

    So, the LinkedIn case is not closed yet. I will try to make you a screen video that you see what I do.

    #5606
    AvatarCharlie
    Keymaster

    Thank you for take time out of your day to create the video :)

    It is very strange to see that the entire process seems to go through the correct stages but there are no access keys retrieved at the end. Is it possible for you to send us amid login credentials to your site? We normally do not ask for these but since you are having some troubles we want to see if there is something we can do to help.

    If you gave us login credentials we would try to setup one of our test accounts to your version of Content Reshaper Pro. If we are unable to setup the accounts then there might be a plugin conflict on your site. If we are able to setup our accounts then there is something with the way you configured your LinkedIn and Facebook accounts.

    If you do send us your login credentials please be sure to mark the reply as private so only we see them, or just email them to us at support@99robots.com

    #5604
    AvatarCharlie
    Keymaster

    I was able to login to your site and test Content Resharer Pro, and here are my conclusions.

    1) I was not able to connect my personal LinkedIn or Facebook accounts. I received the same errors you did.

    2) I created two brand new applications and tried to connect them again to my test site kylebenktest.com. I was able to connect them and everything worked fine.

    3) The with the same LinkedIn and Facebook applications that worked for kylebenktest.com, I changed their Oauth 2.0 endpoints to your site and tried to connect my accounts. I was still unable to connect the accounts.

    My conclusion is that this process works but for whatever reason your hosting provider or something on your site is stopping this authentication. I left my accounts on your site to show you that I did test them, but I removed my client secret from each account.

    If you want to test this further to see if this is an error from the server side I will need to get FTP login credentials to your site. This will allow me to view the debug.log file on your WordPress site to see if there are any server side errors.

    So sorry that this is become a long and complicated process :( I thank you for your patience.

    #5603
    Avatargordon
    Participant

    Hello again.

    I tried to install it on another page on another server… same result. It is not connecting the account to the LinkedIn neither to the Facebook app.

    I tried to debug it a bit. Both pages give an error back (in the authentication process).
    URL to Facebook:
    https://graph.facebook.com/v2.1/oauth/access_token?client_id=***&redirect_uri=http%3A%2F%2Fwww.domain.com%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpsite-reshare-menu%26facebook%3Dauthorization%26account%3DFacebook%2B2&client_secret=***&code=VerrryLongCode
    Response of Facebook:
    {“error”:{“message”:”Missing redirect_uri parameter.”,”type”:”OAuthException”,”code”:191}}

    URL to LinkedIn:
    https://www.linkedin.com/uas/oauth2/accessToken?grant_type=authorization_code&client_id=***&client_secret=***&code=VeryLongCode&redirect_uri=http%3A%2F%2Fwww.domain.com%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpsite-reshare-menu%26linkedin%3Dauthorization%26account%3DLinkedIn
    Response of LinkedIn:
    Array
    (
    [error_description] => missing required parameters, includes an invalid parameter value, parameter more than once. : client_id
    [error] => invalid_request
    )

    Tried half day today to solve it… nothing. Maybe you have an idea?

    #7419
    Avatargordon
    Participant

    Hi.

    New webpage (or just for the forum?), congratulation :)

    That brought me to the question if the former private messages are still not visible to others… they are… and even to not logged in users! Please make it private again or delete my post with the login details!

    Everything else I’ll send you in a few minutes via email.

    Cheers.

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘WP Content Resharer Pro’ is closed to new topics and replies.
-