Home Forums WP Background Takeover Background not clikable, does not overwrite default background

Viewing 20 posts - 1 through 20 (of 27 total)
  • Author
    Posts
  • #6035
    AvatarCharlie
    Keymaster

    Hi!

    We have pretty big website here which contains thousands of articles (and much more visitors). Some of them have a custom background-image which (that feature is supported by Valenti theme which we use.

    I’ve installed your plugin, added some picture with link and tried to overload it everywhere. You can see settings here: AdSettup and Display Settings (here it is displayed only on custom page to not affect a lot our website customers, I know about that).

    Ad following things happen:
    1) At all pages with the custom background it haven’t been loaded at all (for example at main page)
    2) if there was not set any custom background, it happen following: background is under all parts not only left and right side and it’s not clickable. Correct display is following and it should be on the left and right side.

    No error was produced. I’ve deactivated the plugin for this time, but I need to know how to solve it. Could you please help us?

    Best regards
    Karolina from ThinkFood

    #6064
    AvatarCharlie
    Keymaster

    Hello – Welcome to the community :)

    Since all themes are built differently and created by various developers, your website structure may be unique compared to most standard WP sites. Luckily, we anticipated such a scenario and it requires a very simple step to address issues with clickable zones or background takeover images being visible for specific WordPress themes. Please follow the instructions below:

    1. Go to your All Ads page and scroll down until you see a box labeled Advanced Settings.
    2. Open this setting box and change the Main DOM Element for clickable area from body to #cb-outer-container
    3. Click Save Settings.

    Please let us know if there is anything else we can help you with today. All the best.

    #6063
    Avatarradekvana
    Participant

    Hi! Thanks a lot! That solved all our problems! Incredible efficient and fast support!
    Karolina

    #6062
    AvatarCharlie
    Keymaster

    Glad to hear that everything is working now!

    If you have any other questions please let us know and if you are enjoying the plugin please be sure to leave us a review on Code Canyon :)

    #6061
    Avatarradekvana
    Participant

    Maybe one more question – is there any way how to put adds as well on the top of the page?
    another add

    Do you have any manual to download? Or some mockups or something for graphic designers?

    #6060
    AvatarCharlie
    Keymaster

    Background Takeover does not inherently have a way to add a clickable zone to the header of your site, but many people have accomplished this through some custom CSS code.

    If you add this code in your theme’s style.css file or custom CSS editor you will see what I mean.

     div#cb-outer-container {padding-top: 200px !important;} 

    Here is a link to an example PSD if that is what you mean by mockups. If that is not what you mean please let me know :)

    #6059
    Avatarradekvana
    Participant

    Thanks a lot! But one more question – if used provided special css, is “cb-outer-container” applied to all pages or only on pages where your ads plugin is used?

    #6058
    AvatarCharlie
    Keymaster

    The div#cb-outer-container is an element within your theme and has no relation to the Background Takeover plugin. So I am not sure about the other pages on your site.

    My advice would be to just test it out all all types of pages, this way you will know what page layouts it will work on.

    #6057
    AvatarCharlie
    Keymaster

    Background not clikable for me too: http://noticias.mmo.co.mz

    #6056
    AvatarCharlie
    Keymaster

    @toppwap,

    1. Go to your All Ads page and scroll down until you see a box labeled Advanced Settings.
    2. Open this setting box and change the Main DOM Element for clickable area from body to .td-content-wrap
    3. Click Save Settings.

    Please let us know if there is anything else we can help you with today. All the best.

    #6054
    AvatarCharlie
    Keymaster

    @freddo20790,

    Hello – Welcome to the community :)

    1. Go to your All Ads page and scroll down until you see a box labeled Advanced Settings.
    2. Open this setting box and change the Main DOM Element for clickable area from body to #background-wrapper
    3. Click Save Settings.

    Please let us know if there is anything else we can help you with today. All the best.

    #6053
    AvatarCharlie
    Keymaster

    thanks a lot! all works!!

    #6052
    AvatarCharlie
    Keymaster

    @freddo20790,

    Great to hear that everything is working perfectly now. If you are enjoying the plugin please be sure to give us a review on Code Canyon :)

    #6051
    Avatarradekvana
    Participant

    Hi, I have one more question. We use the event calendar. I need to have a specific background on this page: http://www.thinkfood.cz/kalendar/ . Any help for us? Something as specific class or so?

    There is written that there is no ID for this page
    https://theeventscalendar.com/support/forums/topic/how-to-find-the-events-page-id-or-name/

    #6050
    AvatarCharlie
    Keymaster

    @radekvana

    The DOM element for http://www.thinkfood.cz/kalendar/ is #cb-outer-container. After reading the other link you sent me about you can clearly see that The Events Calendar is displaying that page in non-standard way. Here is exactly what they said:

    Our plugin creates a virtual page that is not identified in the standard ways.

    I am not sure how they are displaying this page but like I said the only DOM element for that page is #cb-outer-container. If that does not work, then I am not sure what else can be done since The Events Calendar is displaying the page in a non-standard way.

    #6049
    Avatarradekvana
    Participant

    It works, but the problem is that because on our theme uses background images and video as main picture for Posts. So I need to display ads only on homepage, pages and caledar, but not at posts.

    #6048
    AvatarCharlie
    Keymaster

    @radekvana

    Do you know about the Location setting for the Ad?

    This is where you can customize where an Ad is displayed.

    #6047
    AvatarCharlie
    Keymaster

    same issue here guys http://www.retrogamerzone.com

    #6046
    AvatarCharlie
    Keymaster

    Hello wastedheart82,

    Welcome to the community :)

    Since all themes are built differently and created by various developers, your website structure may be unique compared to most standard WP sites. Luckily, we anticipated such a scenario and it requires a very simple step to address issues with clickable zones or background takeover images being visible for specific WordPress themes. Please follow the instructions below:

    1. Go to your All Ads page and scroll down until you see a box labeled Advanced Settings.
    2. Open this setting box and change the Main DOM Element for clickable area from body to #topribbon
    3. Click Save Settings.

    Please let us know if there is anything else we can help you with today. All the best.

    #6045
    Avatarradekvana
    Participant

    I know, but even if I check all the options without “Posts” it’s not working. If it’s for whole webpage it does work (but it breaks down our Posts, so thats a no-no).

Viewing 20 posts - 1 through 20 (of 27 total)
  • The forum ‘WP Background Takeover’ is closed to new topics and replies.
-