Home Forums WP Background Takeover Ad Disappears

Viewing 20 posts - 1 through 20 (of 21 total)
  • Author
    Posts
  • #12335
    AvatarDustin Cabeal
    Participant

    Hello,

    I’ve set my background takeover and its supposed to run for a month. For some reason though it continues to disappear. At first it was happening every couple of days, now it’s happening twice a day.

    My server does use a cache, but it’s all default so I’m not sure I can do anything about it if it’s affecting it.

    #12339
    AvatarCharlie
    Keymaster

    Hello Dustin,

    Thats strange. What actions do you perform to make the Ad re-appear?

    Do you clear your sites cache?
    Do you re-save the Ad’s settings?

    #12439
    AvatarDustin Cabeal
    Participant

    I have to go in and re-select the image being used. That’s the only why it’s shown up again.

    #12441
    AvatarCharlie
    Keymaster

    So after a certain amount of time the image is just gone from the Ad you need to re-select a new image?

    #12442
    AvatarDustin Cabeal
    Participant

    Yes. The timing is random though. I happen to catch it when it happens. In thinking about it, the first time was after I changed the run date from the default to an actual cut off date. It disappeared then and I hate to change everything back to get it to show up. Since then I haven’t touched it unless the image disappears. But no other settings have been changed.

    #12444
    AvatarCharlie
    Keymaster

    Thats very strange. So after a set period of time the image will just be removed from the Ad and then you have to re-select it.

    Background Takeover uses the default WordPress media library to get the image for the Ad and it saves the attachment ID. Do you happen to know of any plugin on your site that edits or alters your media library in any way?

    #12463
    AvatarDustin Cabeal
    Participant

    Yes actually I use EWWW Image Optimizer as well. Should I try disabling it?

    #12465
    AvatarCharlie
    Keymaster

    I just downloaded the plugin and used it and nothing affected the Ads displaying in any manner.

    Do you have any scheduled tasks that run automatically on your site that might affect Background Takeover? This seems like a problem that is caused by an automated task correct?

    #12469
    AvatarDustin Cabeal
    Participant

    As far as I know I don’t. But I will check and get back to you.

    #12470
    AvatarCharlie
    Keymaster

    Ok sounds great. I look forward to hearing back from you :)

    #12479
    AvatarDustin Cabeal
    Participant

    Sorry for the delay in getting back to you. The only plugin that I have that runs on its own is WP Missed Schedule. Though since I posted this problem I haven’t had it happen since.

    #12542
    AvatarCharlie
    Keymaster

    Ok well try to monitor it and try to see when the Ad disappears so that maybe we can relate it to a background task you have operating.

    #12602
    AvatarDustin Cabeal
    Participant

    Hi Kyle,

    Just wanted to let you know that it just happened again. I’m reselecting the image to get it back up.

    Thanks

    #12603
    AvatarCharlie
    Keymaster

    Was there any automated tasks that just took place before the Ad was removed?

    #12623
    AvatarDustin Cabeal
    Participant

    No, it happened after I posted two articles.

    #12624
    AvatarCharlie
    Keymaster

    Ok so its seems that whenever you save a page the image is completed removed from the Background Takeover Ad. Thats is very strange.

    Do you have nay plugin installed that performs actions on saving or publishing a post? It just seems so weird that this would cause the Ad Image to be removed since they are two totally unrelated things.

    #12625
    AvatarDustin Cabeal
    Participant

    I do have a twitter plugin that publishes automatically now that I think of it. This isn’t the jetpack one, but a separate plugin. Though I do have Jetpack auto-publish to Facebook and Google+ as well.

    #12626
    AvatarCharlie
    Keymaster

    Basically there should really be not action on your site that can remove an image form your Background Takeover Ad unless that action changed the Media ID. Like I said before Background Takeover saves the Media ID of the image you uploaded to your site.

    The only way to truly see exactly what is causing this is to perform a conflict test. You can read about this in our documentation page.

    Testing for WordPress Plugin or Theme Conflict

    Do you have a testing or staging site for your website?

    #12720
    AvatarDustin Cabeal
    Participant

    I don’t have a testing site, I’m pretty amateur at all of this. Here’s a list of plugins I have and I can get you my theme info if needed.

    https://onedrive.live.com/redir?resid=B54511A530006BA3!119731&authkey=!AEYsOFPwf_h3630&v=3&ithint=photo%2cpng

    #12727
    AvatarCharlie
    Keymaster
    This reply has been marked as private.
Viewing 20 posts - 1 through 20 (of 21 total)
  • The forum ‘WP Background Takeover’ is closed to new topics and replies.
-