Home Forums Optin Fire A Couple of Issues

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #14122
    Avatarterry
    Participant

    Howdy Robots,

    I’m having some display issues on my website in a couple of areas. First, the website (which I’ll call “LI” from here on in) is at:

    http://linkedinvestigator.com/

    It is similar to another one of my client’s websites, except the other site is a WPMU site (I’ll call it “NB” from here on in). But the template, plugins, etc. are the same. See:

    http://newportbeachinvestigator.com

    After activating Optin Fire and publishing blogs on LI, I noticed some display issues after scrolling part-way down the page. It’s sporadic though… sometimes the page displays correctly, and sometimes not. Here are some screenshots:

    Screenshot from LI

    Screenshot from LI

    Because the content is different between LI and NB, I couldn’t confirm for sure where the problem was, so I duplicated the blog post and checked that. I AM seeing formatting issues on LI that I’m NOT seeing on the NB site. The LI blog post is at:

    http://linkedinvestigator.com/private-investigator-in-newport-beach-3/

    and the NB post is at:

    http://newportbeachinvestigator.com/blog/private-investigator-in-newport-beach/

    The CTAs on the NB site are inserted as images, while on the LI site, they are inserted as Optin Fire shortcodes. Here is what I saw on the LI blog post:

    Screenshot from LI

    And here’s how the bottom of the page looks on NB:

    Screenshot from LI

    Can you see anything there that you think might be causing this?

    Also, another issue I’m having is that I can’t get the widget to display. I’ve added it to the right sidebar, but it’s not showing.

    I’d appreciate your help with this – thanks so much!

    Terry

    #14127
    AvatarCharlie
    Keymaster

    Hello Terry,

    Welcome to the community :)

    I went to this url – http://linkedinvestigator.com/private-investigator-in-newport-beach-3/ – and I can see that you have two Optin Fires on that page.

    The first one is displaying properly and then second is not, so I am not sure what exactly is causing this problem.

    Also, this may be some sort of styling issue with your theme and its footer menu. If you re-size your browser window (i.e. make it bigger or smaller) the optin will be shown correctly. In addition, when I look at the code I see that the actual Optin Fire code is being added to the correct spot.

    To test to make sure this is not a shortcode issue can you please try to display the Optin via the Display Conditions tab within the optin settings.

    • Set the Display On setting equal to Post and then uncheck the All option.
    • This will show a box where you can show an Optin only on a specific post.
    • Select the post you want to show it on and then remove the shortocde from that post.

    This is still show the Optin on that page but via the Optin setting not shortcode. If it displays correctly then we know its a shortcode issue.

    #14205
    Avatarterry
    Participant

    Hi Kyle,

    Thanks for your reply.

    Okay, I went in and removed the shortcodes, then added the CTAs using the display conditions as you suggested. That *does* seem to fix the layout issue. Hopefully you can figure out what the issue might be there.

    The only way this plugin will work for us is if we can use the shortcode. The main reason is because we need full control over exactly where each CTA is placed. (And we’ve already added multiple shortcodes to the almost 400 posts in the system…) :(

    Fingers and toes crossed… lol.

    Terry

    #14216
    AvatarCharlie
    Keymaster

    I am not sure how familiar you are with CSS and Javascript but I think I might have found the issue.

    The container that holds all of your post content has its height set manually to an exact number. This is why when the shortcode of Optin Fire finally loads into the page it will usually change the height of its container but in your case it does not.

    The container element that seems to be the problem is this #content. If you want to try to add some CSS to your theme temporarily to see what I am add this to your style.css file.

    #content {height: auto !important;}

    Once you see how it affects Optin Fire you can then remove it and figure out the proper way to fix this issue.

    Let me know if you have any more questions :)

    #14571
    Avatarterry
    Participant

    Hi Kyle and crew – Happy New Year!

    That fix did correct the display issue – thanks. Not sure where you saw the original code that manually specified the height… I don’t see it, but this worked, so I think for now that covers that!

    I’m still having trouble with the second issue:

    Also, another issue I’m having is that I can’t get the widget to display. I’ve added it to the right sidebar, but it’s not showing.

    The site is now located at:

    http://linkedinvestigations.com/

    Many thanks for your assistance.

    Terry

    #14572
    Avatarterry
    Participant

    (Go to any page besides the homepage where you can see the right-hand column.) Here’s one, to save you a click: :)

    http://linkedinvestigations.com/private-investigative-services/

    #14576
    AvatarCharlie
    Keymaster

    Hello Terry and Happy New Year :)

    Im glad that we were able to solve the first problem so now lets solve this second problem.

    The link you provided above – http://linkedinvestigations.com/private-investigative-services/ – does not show an Optin within the right-sidebar, like you said.

    Are you sure you are adding it to the correct widget zone on the backend?
    Is the Optin Fire set to On?
    Is the Date Range valid? (i.e. the start and end dates both make sense to display right now)

    #14583
    Avatarterry
    Participant

    Hi Kyle,

    I recreated the widget and tried again, and now it’s working.

    I think I figured out what the problem was… You helped me with custom CSS to remove the background colors for the other Optins I created, and since the widget had a background color too, initially, I was using it there as well. This was the CSS code on the original widget:

    .nnr-of-wrap.nnr-of-wrap-7 .nnr-of-container {
        background-color: transparent !important;
    }

    On the newest one, I didn’t add any custom CSS and it displayed correctly. Maybe you fixed the background color thing in an update? Not sure. In any event, that part is working now.

    Thanks for your help!

    Terry

    #14585
    AvatarCharlie
    Keymaster

    Great! If you need anything else please let me know :)

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Optin Fire’ is closed to new topics and replies.
-